<!DOCTYPE html>
<html>
<head>
    <meta charset="utf-8">
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>
    <title>Juice Lord has no mercy in this week’s Top 5 MN music videos | City Pages</title>
                
                <meta name="keywords" content="Minneapolis news, Minnesota news, Minneapolis events, Minnesota events, Minneapolis City Pages">
    <meta name="description" content="As your least funny coworker has probably noted, people don’t like Mondays.&hellip;">
    <meta itemprop="name" content="Juice Lord has no mercy in this week’s Top 5 MN music videos | City Pages" />    <meta itemprop="description" content="As your least funny coworker has probably noted, people don’t like Mondays.&hellip;" />    <meta itemprop="image" content="http://stmedia.stimg.co/damanmmm.jpg?w=1200&h=630">        <meta name="author" content="Jerard Fagerberg">
<meta itemprop="headline" content="Juice Lord has no mercy in this week’s Top 5 MN music videos">
    <meta property="og:site_name" content="City Pages">
    <meta property="og:type" content="website">
    <meta property="og:title" content="Juice Lord has no mercy in this week’s Top 5 MN music videos | City Pages">
    <meta property="og:url" content="http://www.citypages.com/music/juice-lord-has-no-mercy-in-this-weeks-top-5-mn-music-videos/421678633">
    <meta property="og:description" content="As your least funny coworker has probably noted, people don’t like Mondays.&hellip;">    <meta property="og:image" content="http://stmedia.stimg.co/damanmmm.jpg?w=1200&h=630" />    <meta property="og:image:url" content="http://stmedia.stimg.co/damanmmm.jpg?w=1200&h=630" />            <meta property="og:image:width" content="1200" />        <meta property="og:image:height" content="630" />                <meta property="fb:app_id" content="124697657593506">
            <meta property="twitter:site" content="@citypages">
    <meta name="twitter:card" content="summary">
    <meta property="twitter:title" content="Juice Lord has no mercy in this week’s Top 5 MN music videos | City Pages">
    <meta property="twitter:description" content="As your least funny coworker has probably noted, people don’t like Mondays.&hellip;">
    <meta name="twitter:url" content="http://www.citypages.com/music/juice-lord-has-no-mercy-in-this-weeks-top-5-mn-music-videos/421678633" />
    <meta name="twitter:image" content="http://stmedia.stimg.co/damanmmm.jpg?w=1200&h=630">
    <meta name="twitter:image:src" content="http://stmedia.stimg.co/damanmmm.jpg?w=1200&h=630">
        
        <link rel="canonical" href="http://www.citypages.com/music/juice-lord-has-no-mercy-in-this-weeks-top-5-mn-music-videos/421678633"/>
    <link href='https://fonts.googleapis.com/css?family=Roboto:400,700|Roboto+Condensed|Pathway+Gothic+One|Montserrat:700' rel='stylesheet' type='text/css'>
    <link rel="stylesheet" href="http://www.citypages.com/build/css/app-2e2ccdb22a.css"/>
    <link rel="shortcut icon" href="http://www.citypages.com/img/faviconit/favicon.ico">
<link rel="icon" sizes="16x16 32x32 64x64" href="http://www.citypages.com/img/faviconit/favicon.ico">
<link rel="icon" type="image/png" sizes="196x196" href="http://www.citypages.com/img/faviconit/favicon-192.png">
<link rel="icon" type="image/png" sizes="160x160" href="http://www.citypages.com/img/faviconit/favicon-160.png">
<link rel="icon" type="image/png" sizes="96x96" href="http://www.citypages.com/img/faviconit/favicon-96.png">
<link rel="icon" type="image/png" sizes="64x64" href="http://www.citypages.com/img/faviconit/favicon-64.png">
<link rel="icon" type="image/png" sizes="32x32" href="http://www.citypages.com/img/faviconit/favicon-32.png">
<link rel="icon" type="image/png" sizes="16x16" href="http://www.citypages.com/img/faviconit/favicon-16.png">
<link rel="apple-touch-icon" href="http://www.citypages.com/img/faviconit/favicon-57.png">
<link rel="apple-touch-icon" sizes="114x114" href="http://www.citypages.com/img/faviconit/favicon-114.png">
<link rel="apple-touch-icon" sizes="72x72" href="http://www.citypages.com/img/faviconit/favicon-72.png">
<link rel="apple-touch-icon" sizes="144x144" href="http://www.citypages.com/img/faviconit/favicon-144.png">
<link rel="apple-touch-icon" sizes="60x60" href="http://www.citypages.com/img/faviconit/favicon-60.png">
<link rel="apple-touch-icon" sizes="120x120" href="http://www.citypages.com/img/faviconit/favicon-120.png">
<link rel="apple-touch-icon" sizes="76x76" href="http://www.citypages.com/img/faviconit/favicon-76.png">
<link rel="apple-touch-icon" sizes="152x152" href="http://www.citypages.com/img/faviconit/favicon-152.png">
<link rel="apple-touch-icon" sizes="180x180" href="http://www.citypages.com/img/faviconit/favicon-180.png">
<meta name="msapplication-TileColor" content="#FFFFFF">
<meta name="msapplication-TileImage" content="http://www.citypages.com/img/faviconit/favicon-144.png">
<meta name="msapplication-config" content="http://www.citypages.com/img/faviconit/browserconfig.xml">        <script src="http://www.citypages.com/build/js/header-030ab356af.js"></script>
        <!-- START COMSCORE DIRECT TAG -->
<!-- Begin comScore Tag -->
<script>
    var _comscore = _comscore || [];
    _comscore.push({c1: "2", c2: "8428425"});
    (function () {
        var s = document.createElement("script"), el = document.getElementsByTagName("script")[0];
        s.async = true;
        s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
        el.parentNode.insertBefore(s, el);
    })();
</script>
<noscript><img src="http://b.scorecardresearch.com/p?c1=2&c2=8428425&cv=2.0&cj=1" /></noscript>
<!-- End comScore Tag -->
<!-- END COMSCORE DIRECT TAG -->

<!-- BEGIN GOOGLE ANALYTICS -->
<script>
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

    ga('create', 'UA-5868951-3', 'auto');
    ga('send', 'pageview');

</script>

<!-- END GOOGLE ANALYTICS -->


<script>
    window.dataMapManager = window.dataMapManager || {};
    window.dataMapManager['analyticsVariables'] = {"channel":"Music","prop3":"Article","prop2":"421678633","prop4":"2017-05-09 14:36:43","prop5":"Jerard Fagerberg","prop6":null,"prop7":"Music"};
</script>
    <script src="//d2wy8f7a9ursnm.cloudfront.net/bugsnag-2.min.js" data-apikey="eabd015ffeb86cb12c9ea61c98192340"></script>
    <script type="text/javascript">
        Bugsnag.releaseStage = "prod";
                    Bugsnag.appVersion = "/build/js/b2e4b4a951"
            </script>
    <script type="text/javascript" src="//nexus.ensighten.com/startribune/Bootstrap.js"></script>

    </head>
<body>
            <div class="ads frame" data-vmg-ad="Frame" data-vmg-format="normal"></div>
            <div class="skin-wrapper">
        <div class="skin-wrapper-inner">
            <div class="skin skin-left">
                <div class="skin-image"></div>
            </div>
            <div class="main-container-spacer"></div>
            <div class="skin skin-right">
                <div class="skin-image"></div>
            </div>
        </div>
    </div>
    
    <div class="wrapper">
                <div class="skin-spacer"></div>
                <main class="main-container article-page"  data-cmp-id="421678633">

                            <header class="nav-container row">

                                            <div class="col-sm-12">

                            <div class="billboard row" data-vmg-ad="Billboard" data-vmg-format="normal"></div>
                        </div>
                    
                                            <div class="nav-block col-sm-12">

        <div class="mobile-nav mobile-only row">
        <div class="mobile-nav-inner at-top">
            <div class="mobile-nav-buttons">
                <a data-target="#menuModal" data-toggle="modal" href="#" class="col-xs-2">
                    <span class="icon icon-menu"></span>
                </a>
                <a href="http://www.citypages.com"  title="Latest Minneapolis &amp; St. Paul News and Events | Minneapolis City Pages" class="col-xs-8">
                    <div class="logo-mobile"></div>
                </a>
                <a href="#" class="col-xs-2" data-target="#searchModal" data-toggle="modal" data-search-content-type="All">
                    <span class="icon icon-search"></span>
                </a>
            </div>

                                    
        </div>
    </div>

        <div class="top-block row at-top">
        <div class="top-block-inner">
            <nav class="utility-nav col-sm-12">
                <div class="row">
                    <ul class="col-sm-8">
                                                    <li>
                                <a href="http://www.citypages.com/this-week"
                                   title="This Week&#039;s Issue">This Week&#039;s Issue</a>
                            </li>
                                                    <li>
                                <a href="http://www.citypages.com/slideshows"
                                   title="Photo Galleries">Photo Galleries</a>
                            </li>
                                                    <li>
                                <a href="http://e.startribune.com/Olive/ODN/STCityPages/default.aspx"
                                   title="E-Edition">E-Edition</a>
                            </li>
                                                    <li>
                                <a href="http://www.citypages.com/newsletters"
                                   title="Newsletters">Newsletters</a>
                            </li>
                                                    <li>
                                <a href="http://jobfair.citypages.com"
                                   title="Job Fair">Job Fair</a>
                            </li>
                                                    <li>
                                <a href="http://www.citypages.com/about/contact"
                                   title="Contact Us">Contact Us</a>
                            </li>
                                            </ul>
                                        <ul class="col-sm-4 align-right">
                        <li>
                            <a data-target="#searchModal" data-toggle="modal" data-search-content-type="All">Search
                                <span class="icon icon-search light-gray"></span>
                            </a>
                        </li>
                        <li><a href="https://www.facebook.com/citypages/" target="_blank"><span
                                        class="icon icon-facebook light-gray"></span></a></li>
                        <li><a href="https://twitter.com/citypages" target="_blank"><span
                                        class="icon icon-twitter light-gray"></span></a></li>
                        <li><a href="https://www.instagram.com/citypages/" target="_blank"><span
                                        class="icon icon-instagram light-gray"></span></a></li>
                    </ul>
                                    </div>
            </nav>

            <div class="section-nav col-sm-12">
                <div class="row">

                                        <div class="logo-block col-sm-3">
                        <a href="http://www.citypages.com" title="Latest Minneapolis &amp; St. Paul News and Events | Minneapolis City Pages">
                            <img src="http://www.citypages.com/img/cp_logo-white.png" alt="City Pages">
                        </a>
                    </div>

                    <ul class="nav-menu col-sm-9">
                        
                                                        <li class="nav-item">
                                <a href="http://www.citypages.com/news" title="News">News</a>

                                                                    <div class="category-nav">

                                                                                
                                                                                                                            <ul class="feed-block">
                                                                                                    <li class="col-sm-4">
                                                                                                                                                                        <a href="http://www.citypages.com/news/former-hodges-campaign-manager-claims-he-resigned-over-racial-slur/421725853"
                                                           class="list-title">Former Hodges campaign manager claims he resigned over &#039;racial slur&#039;</a>
                                                        <span class="byline">

                                            May 9
            
      
                              by <a href="http://www.citypages.com/about/staff/mike-mullen/372121262" title="Mike Mullen">Mike Mullen</a>
  
  
</span>
                                                    </li>
                                                                                                    <li class="col-sm-4">
                                                                                                                                                                        <a href="http://www.citypages.com/news/hennepin-sheriffs-2-year-stonewall-to-keep-its-surveillance-technology-a-secret/421673273"
                                                           class="list-title">Hennepin sheriff&#039;s 2-year stonewall to keep its surveillance technology a secret</a>
                                                        <span class="byline">

                                            May 9
            
      
                              by <a href="http://www.citypages.com/about/staff/susan-du/372121552" title="Susan Du">Susan Du</a>
  
  
</span>
                                                    </li>
                                                                                                    <li class="col-sm-4">
                                                                                                                                                                        <a href="http://www.citypages.com/news/uptown-sucks-except-when-it-doesnt/421654053"
                                                           class="list-title">Uptown sucks. Except when it doesn&#039;t.</a>
                                                        <span class="byline">

                                            May 9
            
      
              by City Pages Readers
  
  
</span>
                                                    </li>
                                                                                            </ul>
                                        
                                    </div>
                                
                            </li>
                        
                                                        <li class="nav-item">
                                <a href="http://www.citypages.com/music" title="Music">Music</a>

                                                                    <div class="category-nav">

                                                                                                                            <ul class="sub-categories">
                                                                                                    <li><a href="http://www.citypages.com/concerts"
                                                           title="Concerts">Concerts</a>
                                                    </li>
                                                                                            </ul>
                                        
                                                                                                                            <ul class="feed-block">
                                                                                                    <li class="col-sm-4">
                                                                                                                                                                        <a href="http://www.citypages.com/music/imagine-dragons-rocks-biggest-band-whether-you-like-it-or-not-coming-to-st-paul/421758403"
                                                           class="list-title">Imagine Dragons -- rock&#039;s biggest band, whether you like it or not -- coming to St. Paul</a>
                                                        <span class="byline">

                                            12:06 p.m.
            
      
                              by <a href="http://www.citypages.com/about/staff/jay-boller/372121392" title="Jay Boller">Jay Boller</a>
  
  
</span>
                                                    </li>
                                                                                                    <li class="col-sm-4">
                                                                                                                                                                        <a href="http://www.citypages.com/music/juice-lord-has-no-mercy-in-this-weeks-top-5-mn-music-videos/421678633"
                                                           class="list-title">Juice Lord has no mercy in this week’s Top 5 MN music videos</a>
                                                        <span class="byline">

                                            9:36 a.m.
            
      
              by Jerard Fagerberg
  
  
</span>
                                                    </li>
                                                                                                    <li class="col-sm-4">
                                                                                                                                                                        <a href="http://www.citypages.com/music/back-to-the-city-video-podcast-har-mar-superstar-gets-set-for-another-great-summer/421739663"
                                                           class="list-title">Back to the City video podcast: Har Mar Superstar gets set for another great summer</a>
                                                        <span class="byline">

                                            2:43 p.m.
            
      
              by Simon Calder
  
  
</span>
                                                    </li>
                                                                                            </ul>
                                        
                                    </div>
                                
                            </li>
                        
                                                        <li class="nav-item">
                                <a href="http://www.citypages.com/restaurants" title="Food &amp; Drink">Food &amp; Drink</a>

                                                                    <div class="category-nav">

                                                                                                                            <ul class="sub-categories">
                                                                                                    <li><a href="http://www.citypages.com/restaurants/guide"
                                                           title="Restaurant Guide">Restaurant Guide</a>
                                                    </li>
                                                                                                    <li><a href="http://www.citypages.com/restaurants/reviews"
                                                           title="Restaurant Reviews">Restaurant Reviews</a>
                                                    </li>
                                                                                                    <li><a href="http://www.citypages.com/restaurants/favorite-dishes"
                                                           title="Favorite Dishes">Favorite Dishes</a>
                                                    </li>
                                                                                            </ul>
                                        
                                                                                                                            <ul class="feed-block">
                                                                                                    <li class="col-sm-4">
                                                                                                                                                                        <a href="http://www.citypages.com/restaurants/where-the-wild-things-are-where-to-eat-morels-fiddleheads-and-ramps-right-now/421687483"
                                                           class="list-title">Where the wild things are: Where to eat morels, fiddleheads, and ramps right now</a>
                                                        <span class="byline">

                                            May 9
            
      
                              by <a href="http://www.citypages.com/about/staff/mecca-bos/372121752" title="Mecca Bos">Mecca Bos</a>
  
  
</span>
                                                    </li>
                                                                                                    <li class="col-sm-4">
                                                                                                                                                                        <a href="http://www.citypages.com/restaurants/kitchen-workers-need-opportunities-for-growth-besides-opening-your-own-place/421686673"
                                                           class="list-title">Kitchen workers need opportunities for growth besides &quot;opening your own place&quot;</a>
                                                        <span class="byline">

                                            May 9
            
      
                              by <a href="http://www.citypages.com/about/staff/mecca-bos/372121752" title="Mecca Bos">Mecca Bos</a>
  
  
</span>
                                                    </li>
                                                                                                    <li class="col-sm-4">
                                                                                                                                                                        <a href="http://www.citypages.com/restaurants/when-i-die-its-on-you-edina-911-caller-asks-dispatcher-about-lasagna/421645714"
                                                           class="list-title">&#039;When I die it&#039;s on you&#039;: Edina 911 caller asks dispatcher about lasagna</a>
                                                        <span class="byline">

                                            May 8
            
      
                              by <a href="http://www.citypages.com/about/staff/mike-mullen/372121262" title="Mike Mullen">Mike Mullen</a>
  
  
</span>
                                                    </li>
                                                                                            </ul>
                                        
                                    </div>
                                
                            </li>
                        
                                                        <li class="nav-item">
                                <a href="http://www.citypages.com/arts" title="Arts &amp; Leisure">Arts &amp; Leisure</a>

                                                                    <div class="category-nav">

                                                                                
                                                                                                                            <ul class="feed-block">
                                                                                                    <li class="col-sm-4">
                                                                                                                                                                        <a href="http://www.citypages.com/arts/minneapolis-parks-rec-did-a-killer-job-with-its-summer-movie-schedule/421750324"
                                                           class="list-title">Minneapolis Parks &amp; Rec did a killer job with its summer movie schedule</a>
                                                        <span class="byline">

                                            10:04 a.m.
            
      
                              by <a href="http://www.citypages.com/about/staff/jessica-armbruster/372121462" title="Jessica Armbruster">Jessica Armbruster</a>
  
  
</span>
                                                    </li>
                                                                                                    <li class="col-sm-4">
                                                                                                                                                                        <a href="http://www.citypages.com/arts/mason-jennings-and-benson-ramsey-take-a-break-from-music-to-share-horse-doodles-and-photography/421654953"
                                                           class="list-title">Mason Jennings and Benson Ramsey take a break from music to share horse doodles and photography</a>
                                                        <span class="byline">

                                            11:30 a.m.
            
      
              by Erica Rivera
  
  
</span>
                                                    </li>
                                                                                                    <li class="col-sm-4">
                                                                                                                                                                        <a href="http://www.citypages.com/arts/primes-debut-little-wars-doesnt-quite-have-the-ammo-for-a-great-female-led-production/421635963"
                                                           class="list-title">Prime&#039;s debut &#039;Little Wars&#039; doesn&#039;t quite have the ammo for a great female-led production</a>
                                                        <span class="byline">

                                            May 9
            
      
              by Jay Gabler
  
  
</span>
                                                    </li>
                                                                                            </ul>
                                        
                                    </div>
                                
                            </li>
                        
                                                        <li class="nav-item">
                                <a href="http://www.citypages.com/calendar" title="Calendar">Calendar</a>

                                
                            </li>
                        
                                                        <li class="nav-item">
                                <a href="http://www.citypages.com/movies" title="Movies">Movies</a>

                                                                    <div class="category-nav">

                                                                                                                            <ul class="sub-categories">
                                                                                                    <li><a href="http://www.citypages.com/movies/reviews"
                                                           title="Film Reviews">Film Reviews</a>
                                                    </li>
                                                                                            </ul>
                                        
                                                                                                                            <ul class="feed-block">
                                                                                                    <li class="col-sm-4">
                                                                                                                                                                        <a href="http://www.citypages.com/movies/5-best-movies-coming-to-netflix-in-may/421060894"
                                                           class="list-title">5 best movies coming to Netflix in May</a>
                                                        <span class="byline">

                                            May 3
            
      
              by Tony Libera
  
  
</span>
                                                    </li>
                                                                                                    <li class="col-sm-4">
                                                                                                                                                                        <a href="http://www.citypages.com/movies/lost-city-of-z-is-fertile-new-territory-for-a-master-filmmaker/420393763"
                                                           class="list-title">&#039;Lost City of Z&#039; is fertile new territory for a master filmmaker</a>
                                                        <span class="byline">

                                            April 27
            
      
              by Michael Nordine
  
  
</span>
                                                    </li>
                                                                                                    <li class="col-sm-4">
                                                                                                                                                                        <a href="http://www.citypages.com/music/12-rods-documentary-remembers-what-might-have-been/419631543"
                                                           class="list-title">12 Rods documentary remembers what might have been</a>
                                                        <span class="byline">

                                            April 20
            
      
              by Austin Gerth
  
  
</span>
                                                    </li>
                                                                                            </ul>
                                        
                                    </div>
                                
                            </li>
                        
                                                        <li class="nav-item">
                                <a href="http://www.citypages.com/best-of" title="Best Of">Best Of</a>

                                
                            </li>
                        
                                                        <li class="nav-item">
                                <a href="http://www.citypages.com/promotions" title="Promotions">Promotions</a>

                                                                    <div class="category-nav">

                                                                                                                            <ul class="sub-categories">
                                                                                                    <li><a href="http://www.citypages.com/promotions/free-stuff"
                                                           title="Free Stuff">Free Stuff</a>
                                                    </li>
                                                                                                    <li><a href="http://www.citypages.com/promotions/events"
                                                           title="Promotional Events">Promotional Events</a>
                                                    </li>
                                                                                                    <li><a href="http://www.citypages.com/promotions/street-team"
                                                           title="Street Team">Street Team</a>
                                                    </li>
                                                                                                    <li><a href="http://www.citypages.com/promotions/join-street-team"
                                                           title="Join The Street Team">Join The Street Team</a>
                                                    </li>
                                                                                            </ul>
                                        
                                                                                
                                    </div>
                                
                            </li>
                                            </ul>

                </div>
            </div>

                                        <div id="readingBar" class="currently-reading col-sm-12">
                    <div class="row">

                                                <div class="col-sm-12 next-article">
                            <strong>Next</strong>
                            <a href="http://www.citypages.com/music/back-to-the-city-video-podcast-har-mar-superstar-gets-set-for-another-great-summer/421739663">Back to the City video podcast: Har Mar Superstar gets set for another great summer</a>
                        </div>

                        <div id="progressBar"></div>
                    </div>
                </div>
                                                            </div>
    </div>

</div>
                    
                </header>
            
                
                            <div class="content-area row">

                        <header class="col-sm-12 title-row">
        <h1>Juice Lord has no mercy in this week’s Top 5 MN music videos</h1>
        <span class="byline">

            Tuesday, May 9, 2017
      
              by Jerard Fagerberg
  
      in <a href="http://www.citypages.com/music" title="Music">Music</a>
  
</span>
    </header>

                    <div class="col-sm-12 table-block">
                        <div class="left-col">

                                <div class="article-block">
                <div class="row">
            <div class="col-sm-12">

                                    <img src="http://stmedia.stimg.co/damanmmm.jpg?w=800" alt="itemprop" class="intro-image">
    <p class="row ">
                    <span class="caption col-sm-8">Juice Lord.</span>
                            <span class="caption col-sm-4 align-right">YouTube</span>
            </p>
                
                

<div id="" class="share-block ">
    <div class="share-buttons">
        <a class="circle st-share-link" data-st-share-service="facebook" data-st-share-count-selector=".share-count-facebook" data-st-share-url="http://www.citypages.com/music/juice-lord-has-no-mercy-in-this-weeks-top-5-mn-music-videos/421678633" target="_blank">
            <span class="icon icon-facebook mid-gray"></span>
            <span class="number share-count-facebook"></span>
        </a>
        <a class="circle st-share-link" data-st-share-service="twitter"  data-st-share-count-selector=".share-count-twitter" data-st-share-image="http://stmedia.stimg.co/damanmmm.jpg?w=600&amp;h=600" data-st-share-title="Juice Lord has no mercy in this week’s Top 5 MN music videos" data-st-share-url="http://www.citypages.com/music/juice-lord-has-no-mercy-in-this-weeks-top-5-mn-music-videos/421678633" target="_blank">
            <span class="icon icon-twitter mid-gray"></span>
            <span class="number share-count-twitter"></span>
        </a>
        <a class="circle st-share-link" data-st-share-service="googleplus" data-st-share-url="http://www.citypages.com/music/juice-lord-has-no-mercy-in-this-weeks-top-5-mn-music-videos/421678633" target="_blank">
            <span class="icon icon-google mid-gray"></span>
            <span class="number share-count-google"></span>
        </a>
        <a class="circle has-number st-share-link"  data-st-share-service="reddit" data-st-share-count-selector=".share-count-reddit" data-st-share-url="http://www.citypages.com/music/juice-lord-has-no-mercy-in-this-weeks-top-5-mn-music-videos/421678633" data-st-share-title="Juice Lord has no mercy in this week’s Top 5 MN music videos" target="_blank">
            <span class="icon icon-reddit mid-gray"></span>
            <span class="number share-count-reddit">0</span>
        </a>
        <a class="circle" href="/cdn-cgi/l/email-protection#417e3234232b2422357c07332e2c6473710228353864737111202624326472006473710b342822246473710d2e33256473712920326473712f2e6473712c24332238647371282f647371352928326473713624242a64047364797164787832647371152e31647371746473710c0f6473712c34322822647371372825242e3267202c317a232e25387c07332e2c6473710228353864737111202624326472006473716471006471000b342822246473710d2e33256473712920326473712f2e6473712c24332238647371282f647371352928326473713624242a64047364797164787832647371152e31647371746473710c0f6473712c34322822647371372825242e32647100647100647100647100293535316472006473076473073636366f2228353831202624326f222e2c6473072c343228226473072b342822246c2d2e33256c2920326c2f2e6c2c243322386c282f6c352928326c3624242a326c352e316c746c2c2f6c2c343228226c372825242e32647307757370777679777272">
            <span class="icon icon-mail mid-gray"></span>
            <span class="number"></span>
        </a>
        <a class="circle tablet-hide mobile-hide" href="javascript:window.print()">
            <span class="icon icon-print mid-gray"></span>
            <span class="number"></span>
        </a>
    </div>
</div>

                <div class="article-intro"><p>As your least funny coworker has probably noted, people don’t like Mondays.</p></div>
            </div>
        </div>
        
                             
        <div class="row">
            <div class="col-sm-12 table-block">

                                    

<div id="shareBlock" class="share-block hide-mobile">
    <div class="share-buttons">
        <a class="circle st-share-link" data-st-share-service="facebook" data-st-share-count-selector=".share-count-facebook" data-st-share-url="http://www.citypages.com/music/juice-lord-has-no-mercy-in-this-weeks-top-5-mn-music-videos/421678633" target="_blank">
            <span class="icon icon-facebook mid-gray"></span>
            <span class="number share-count-facebook"></span>
        </a>
        <a class="circle st-share-link" data-st-share-service="twitter"  data-st-share-count-selector=".share-count-twitter" data-st-share-image="http://stmedia.stimg.co/damanmmm.jpg?w=600&amp;h=600" data-st-share-title="Juice Lord has no mercy in this week’s Top 5 MN music videos" data-st-share-url="http://www.citypages.com/music/juice-lord-has-no-mercy-in-this-weeks-top-5-mn-music-videos/421678633" target="_blank">
            <span class="icon icon-twitter mid-gray"></span>
            <span class="number share-count-twitter"></span>
        </a>
        <a class="circle st-share-link" data-st-share-service="googleplus" data-st-share-url="http://www.citypages.com/music/juice-lord-has-no-mercy-in-this-weeks-top-5-mn-music-videos/421678633" target="_blank">
            <span class="icon icon-google mid-gray"></span>
            <span class="number share-count-google"></span>
        </a>
        <a class="circle has-number st-share-link"  data-st-share-service="reddit" data-st-share-count-selector=".share-count-reddit" data-st-share-url="http://www.citypages.com/music/juice-lord-has-no-mercy-in-this-weeks-top-5-mn-music-videos/421678633" data-st-share-title="Juice Lord has no mercy in this week’s Top 5 MN music videos" target="_blank">
            <span class="icon icon-reddit mid-gray"></span>
            <span class="number share-count-reddit">0</span>
        </a>
        <a class="circle" href="/cdn-cgi/l/email-protection#1e216d6b7c747b7d6a23586c71733b2c2e5d776a673b2c2e4e7f797b6d3b2d5f3b2c2e546b777d7b3b2c2e52716c7a3b2c2e767f6d3b2c2e70713b2c2e737b6c7d673b2c2e77703b2c2e6a76776d3b2c2e697b7b753b5b2c3b262e3b27276d3b2c2e4a716e3b2c2e2b3b2c2e53503b2c2e736b6d777d3b2c2e68777a7b716d387f736e257c717a6723586c71733b2c2e5d776a673b2c2e4e7f797b6d3b2d5f3b2c2e3b2e5f3b2e5f546b777d7b3b2c2e52716c7a3b2c2e767f6d3b2c2e70713b2c2e737b6c7d673b2c2e77703b2c2e6a76776d3b2c2e697b7b753b5b2c3b262e3b27276d3b2c2e4a716e3b2c2e2b3b2c2e53503b2c2e736b6d777d3b2c2e68777a7b716d3b2e5f3b2e5f3b2e5f3b2e5f766a6a6e3b2d5f3b2c583b2c58696969307d776a676e7f797b6d307d71733b2c58736b6d777d3b2c58746b777d7b3372716c7a33767f6d33707133737b6c7d67337770336a76776d33697b7b756d336a716e332b33737033736b6d777d3368777a7b716d3b2c582a2c2f282926282d2d">
            <span class="icon icon-mail mid-gray"></span>
            <span class="number"></span>
        </a>
        <a class="circle tablet-hide mobile-hide" href="javascript:window.print()">
            <span class="icon icon-print mid-gray"></span>
            <span class="number"></span>
        </a>
    </div>
</div>
                
                <div class="left-col-content">

                    
                    
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                
                                                                                
                                                            
                                                                                                                                                            <p>Maybe you noticed that our Local Frames video roundup fell on Tuesday last week, and that’s the case again today. And forever on into the future. Because having a deadline first thing Monday morning sure is a pain in the ass.</p>
                                                                            
                            
                                                                                                                        <p>We didn’t want to go as far as posting on Friday, since that’s when The Current and Reviler both have their own video roundups, so Tuesday it is. If Local Frames was the lone highlight of your Monday morning, sorry folks. Adjust your content consumption schedules accordingly.</p>
                                                                            
                            
                                                                                                                        <p><strong>Juice Lord -- “It Ain't Hard to Tell” (PREMIERE)</strong></p>
                                                                            
                            
                                                                                                                        <p>21-year-old St. Paul rapper <a href="https://soundcloud.com/juicelawwd">Juice Lord</a> is fronting the next wave of lyricists from the Twin Cities. Especially now that the young poet has teamed with Twin Cities mainstay Tek to produce a new album, the fact that Juice Lord is on an unstoppable come-up has become damn near undeniable. And that’s more or less the thesis behind his new single “It Ain’t Hard to Tell,” featured here for the first time.</p>
                                                                            
                            
                                                                                                                        <p>Over Tek’s soulful feather of a beat, Juice sounds composed as ever. Verse to verse, you can hear the determination in his voice -- he’s ready to lay his shoulder into the rap game and push ‘til he cracks the ranks of the local greats. M&amp;A Productions provide the visuals to accompany the song, and the team positions Juice as a despot at the head of his disciples. It feels like a movement is coming.</p>
                                                                                                                                            <div class="inject-ad desktop tablet leaderboard"></div>
                            
                            
                                                                                                                        <p><div class="youtube-wrapper"><iframe width="560" height="315" src="https://www.youtube.com/embed/DqFnC6iOV40" frameborder="0" allowfullscreen=""></iframe></div></p>
                                                                                                                    <p><strong>Hope Country -- “Falling Away”</strong></p>
                                                                            
                            
                                                                                                                        <p>There’s a gaggle of intimate, baroque video series in the Twin Cities, and despite that, the launch of Pony Rug still stands apart. The audio quality is extremely high and the tones produced in the well-wooded studio are warm and silky.</p>
                                                                            
                                                                                            <div class="inject-ad mobile leaderboard"></div>
                            
                                                                                                                        <p>The first entrant in this series is from heartfelt Wisconsin singer-songwriter Brent Johnson's <a href="https://www.hopecountrymusic.com/">Hope Country</a> project, the opener of last year's self-titled LP. In the confines of Pony Rug, Brent Johnson sings with unsoothable despondency, like he’s calling out for intervention from the Lord. But when only a camera and a microphone appear, he does what he can with those.</p>
                                                                            
                            
                                                                                                                        <p><div class="youtube-wrapper"><iframe width="560" height="315" src="https://www.youtube.com/embed/HgoOOtaRem0" frameborder="0" allowfullscreen=""></iframe></div></p>
                                                                                                                    <p><strong>The Dames -- “Head of State”</strong></p>
                                                                            
                            
                                                                                                                        <p>Hilarious anti-Trump videos will always have a home at Local Frames, but what makes this submission from <a href="https://thedames.bandcamp.com/">the Dames</a> so distinct is that the song was written 19 years before The Donald was sworn in. The newly reunited Dames found some historical synchronicity between their bygone outrage at The Machine and the current state of the U.S. government, which made “Head of State” an obvious candidate for the Duluth Homegrown Music Video Fest.</p>
                                                                            
                            
                                                                                                                        <p>Local director Brian Barber was assigned the song as part of the festival protocol, and he knew exactly which tiny-handed wannabe dictator to direct its disgust at. He slapped together a grotesque trio of puppets to stand in for the band, and the fireworks they produce are nearly enough to rescue their world from their fate.</p>
                                                                            
                            
                                                                                                                        <p>The Dames will be at the Entry on June 3.</p>
                                                                            
                            
                                                                                                                        <p><iframe src="https://player.vimeo.com/video/214380611" width="640" height="360" frameborder="0" webkitallowfullscreen="" mozallowfullscreen="" allowfullscreen=""></iframe></p>
                                                                                                                    <p><strong>Chad Erickson and the Untimely -- “Save Yourself”</strong></p>
                                                                                                                                                                                    <div class="inject-ad desktop tablet leaderboard"></div>
                                                            
                            
                                                                                                                        <p>This year, <a href="http://www.citypages.com/best-of/2017/music/mercies-may/419537763">2016 City Pages Best Music Video Director Mercies May</a> has already teamed up with one regular partner, <a href="http://survivingthegoldenage.com/ecid-gentrified-utopia-official-music-video/">Ecid</a>, and now he continues his victory lap by framing up constant collaborators <a href="https://www.chadericksonandtheuntimely.com/">Chad Erickson and the Untimely</a> for their new single “Save Yourself.” CEATU are “a hard rock band that rocks so hard it will make you rock hard as a rock” and the video draws influence from B-horror to create a sleazy scene.</p>
                                                                            
                            
                                                                                                                        <p>In “Save Yourself,” a night at the strip club turns into a sexy vampire misadventure (think From Dusk ‘Til Dawn) while the band does their best to escape with their arteries intact. The song itself is a devilish sneer that comes down with a meaty hammer towards the end -- just in time for the bloodshed.</p>
                                                                            
                            
                                                                                                                        <p><div class="youtube-wrapper"><iframe width="560" height="315" src="https://www.youtube.com/embed/9GTzFTO1vy8" frameborder="0" allowfullscreen=""></iframe></div></p>
                                                                                                                    <p><strong>Spencer Joles -- “Unfold”</strong></p>
                                                                            
                                                                                                                                    <div class="inject-ad mobile leaderboard"></div>
                                                            
                                                                                                                        <p>Spencer Joles has a rich musical life outside of his surprise 2016 hip-hop collaboration with Nazeem. “Unfold” demonstrates that the sometimes-producer is also a wonderfully somber singer-songwriter.</p>
                                                                            
                            
                                                                                                                        <p>The first track of the upcoming self-titled album, “Unfold” is a bout of self-exploration, with Joles traipsing bridges, riverbanks, and train tracks looking for understanding in the fallout of a broken relationship. The video is also directed by Joles, who seems to be undergoing a creative renaissance.</p>
                                                                            
                            
                                                                                                                        <p><div class="youtube-wrapper"><iframe width="560" height="315" src="https://www.youtube.com/embed/OpD4LksEqmk" frameborder="0" allowfullscreen=""></iframe></div></p>
                                                                                                                    <p><em>Dream of seeing your video appear in Local Frames? Email writer Jerard Fagerberg at <a class="__cf_email__" href="/cdn-cgi/l/email-protection" data-cfemail="e78d80818680829585829580a7808a868e8bc984888ac9">[email&#160;protected]</a><script data-cfhash='f9e31' type="text/javascript">/* <![CDATA[ */!function(t,e,r,n,c,a,p){try{t=document.currentScript||function(){for(t=document.getElementsByTagName('script'),e=t.length;e--;)if(t[e].getAttribute('data-cfhash'))return t[e]}();if(t&&(c=t.previousSibling)){p=t.parentNode;if(a=c.getAttribute('data-cfemail')){for(e='',r='0x'+a.substr(0,2)|0,n=2;a.length-n;n+=2)e+='%'+('0'+('0x'+a.substr(n,2)^r).toString(16)).slice(-2);p.replaceChild(document.createTextNode(decodeURIComponent(e)),c)}p.removeChild(t)}}catch(u){}}()/* ]]> */</script></em></p>
                                                                            
                            
                                                                                                                        



                                                                                    </div>

            </div>
        </div>
    </div>

    <div class="col-md-12 section-block">

    <div class="row">
        <h2 class="section-label">Comments</h2>

        <div class="comment-block">
            <div id="fb-root"></div>
<script>(function(d, s, id) {
        var js, fjs = d.getElementsByTagName(s)[0];
        if (d.getElementById(id)) return;
        js = d.createElement(s); js.id = id;
        js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
        fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<div class="fb-comments" data-mobile="true" data-href="http://www.citypages.com/music/juice-lord-has-no-mercy-in-this-weeks-top-5-mn-music-videos/421678633" data-width="500" data-numposts="5"></div>        </div>

        <div class="yieldmo-container">
            <div class="yieldmo-placement"><div id="ym_926737013385403407" data-yieldmo-id="926737013385403407" data-vmg-ad="Yieldmo" class="yieldmo ads ym"></div></div>
        </div>
    </div>
</div>

            <img class="trackerImage hidden hidden-print" src="http://apps.startribune.com/most_popular/?cmd=inc&amp;type=view&amp;section=%2Fmusic&amp;story_id=421678633&amp;domain=citypages.com">
    
                        </div>
                        <div class="right-col-static" id="rightCol">
                            <div id="rightColInner">

                                
    
    
    
            <div data-zone-2-id="377269611"></div>
                        <div class="mobile-width-section" data-zone="2">
        <div class="ads middle" data-vmg-ad="Middle" data-vmg-format="lazy"></div>
    </div>
        <div class="mobile-width-section" data-module-id="382443491" data-module-type="search-query" data-zone="2">
        
<div class="border-block feed-block event-block">

                        <h3 class="section-label">Happening Today</h3>
            <hr/>
            
    <ul class="article-list">
                                                <li>
                                                                                                    <div class="feed-content no-photo">
                                                    <a class="list-title" href="http://www.citypages.com/calendar/guillermo-del-toro-at-home-with-monsters-8274994" title="Guillermo del Toro: At Home with Monsters">Guillermo del Toro: At Home with Monsters</a>
                                            </div>
                    <span class="byline">
                                                                                                May 9
            
                                                                            at <a href="http://www.citypages.com/location/minneapolis-institute-of-art-6661177">Minneapolis Institute of Art</a>
                                            </span>
                                                                        <li>
                                                                                                    <div class="feed-content no-photo">
                                                    <a class="list-title" href="http://www.citypages.com/calendar/maep-alison-hiltner-8274995" title="MAEP: Alison Hiltner">MAEP: Alison Hiltner</a>
                                            </div>
                    <span class="byline">
                                                                                                May 9
            
                                                                            at <a href="http://www.citypages.com/location/minneapolis-institute-of-art-6661177">Minneapolis Institute of Art</a>
                                            </span>
                                                                        <li>
                                                                                                    <div class="feed-content no-photo">
                                                    <a class="list-title" href="http://www.citypages.com/calendar/the-beautiful-brain-drawings-of-santiago-ramon-y-cajal-8397797" title="The Beautiful Brain: Drawings of Santiago Ramón y Cajal">The Beautiful Brain: Drawings of Santiago Ramón y Cajal</a>
                                            </div>
                    <span class="byline">
                                                                                                May 9
            
                                                                            at <a href="http://www.citypages.com/location/frederick-r-weisman-art-museum-6661175">Frederick R. Weisman Art Museum</a>
                                            </span>
                                                                        <li>
                                                                                                    <div class="feed-content no-photo">
                                                    <a class="list-title" href="http://www.citypages.com/calendar/the-weather-diaries/413060063" title="The Weather Diaries">The Weather Diaries</a>
                                            </div>
                    <span class="byline">
                                                                                                May 9
            
                                                                            at <a href="http://www.citypages.com/location/american-swedish-institute-6662359">American Swedish Institute</a>
                                            </span>
                                                                                </ul>

            <hr>
        <p><a href="http://www.citypages.com/calendar" class="cta-link">SEE MORE EVENTS</a></p>
    
</div>
    </div>
                    <div class="mobile-width-section" data-module-id="380715171" data-module-type="link-list" data-zone="2">
        
<div class="social-block">
    <div class="inner row">

        <div class="col-sm-6 vertical-center">
            <div>
                <p>Stay Up to Date With</p>
                <strong>CityPages Music</strong>
            </div>
        </div>

        <div class="col-sm-6">
            <ul>
                                                            <li>
                            <a href="/newsletters?selected=music">
                                <span class="icon icon-mail red"></span>
                                <span class="link-text">Newsletter Sign Up</span>
                            </a>
                        </li>
                                            <li>
                            <a href="https://www.facebook.com/gimmenoiseblog/">
                                <span class="icon icon-facebook red"></span>
                                <span class="link-text">Subscribe On Facebook</span>
                            </a>
                        </li>
                                            <li>
                            <a href="http://www.twitter.com/citypagesmusic">
                                <span class="icon icon-twitter red"></span>
                                <span class="link-text">Follow On Twitter</span>
                            </a>
                        </li>
                                                </ul>
        </div>

    </div>
</div>
    </div>
        <div class="mobile-width-section" data-zone="2">
        <div class="ads middle" data-vmg-ad="Middle" data-vmg-format="lazy"></div>
    </div>
                    <div class="mobile-width-section" data-module-id="377263051" data-module-type="section" data-zone="2">
        <div class="gray-container">
    <div class="col-sm-12 border-block">
        <h3 class="section-label">Free Stuff</h3>
        <hr>
        <div class="contest-row row">
                            <div class="link-block">
                    <a href="http://www.citypages.com/promotions/free-stuff/win-city-pages-beerfest-vip-prize-pack-over-700-in-value/421673173" title="Win City Pages Beerfest VIP Prize Pack Over $700 in Value">Win City Pages Beerfest VIP Prize Pack Over $700 in Value</a>
                </div>
                            <div class="link-block">
                    <a href="http://www.citypages.com/promotions/free-stuff/enter-to-win-canterbury-park-daily-double-pack/421640984" title="Enter to Win Canterbury Park Daily Double Pack">Enter to Win Canterbury Park Daily Double Pack</a>
                </div>
                            <div class="link-block">
                    <a href="http://www.citypages.com/promotions/free-stuff/enter-for-a-chance-to-win-american-wrestler-the-wizard-on-digital-hd/420295203" title="Enter for a Chance to Win American Wrestler: The Wizard on Digital HD">Enter for a Chance to Win American Wrestler: The Wizard on Digital HD</a>
                </div>
                            <div class="link-block">
                    <a href="http://www.citypages.com/promotions/free-stuff/win-tickets-to-mixtape-and-25-to-kierans-irish-pub/420262183" title="Win Tickets to MIXTAPE and $25 to Kieran&#039;s Irish Pub">Win Tickets to MIXTAPE and $25 to Kieran&#039;s Irish Pub</a>
                </div>
                    </div>
    </div>
</div>    </div>
        <div class="mobile-width-section" data-zone="2">
        <div class="ads middle" data-vmg-ad="Middle" data-vmg-format="lazy"></div>
    </div>
            

                            </div>
                        </div>
                    </div>

                        <div class="col-sm-12 table-block">
        <div class="left-col">
                        
    <div class="article-block border-block feed-block col-sm-12 primary-feed">
                    <h2 class="section-label">More from Music</h2>
        
    <ul class="article-list">
                                
                                                                                
                <li>
                                                                                                    <a href="http://www.citypages.com/music/imagine-dragons-rocks-biggest-band-whether-you-like-it-or-not-coming-to-st-paul/421758403" title="Imagine Dragons -- rock&#039;s biggest band, whether you like it or not -- coming to St. Paul">
                        <div class="feed-image-bg " style="background-image: url('http://stmedia.stimg.co/dragon+gallery071314088.JPG?w=390')"></div>
                    </a>
                                        <div class="feed-content">
                        <a class="list-title" href="http://www.citypages.com/music/imagine-dragons-rocks-biggest-band-whether-you-like-it-or-not-coming-to-st-paul/421758403" title="Imagine Dragons -- rock&#039;s biggest band, whether you like it or not -- coming to St. Paul">Imagine Dragons -- rock&#039;s biggest band, whether you like it or not -- coming to St. Paul</a>

                        
                        <span class="byline">

                                            12:06 p.m.
            
      
                              by <a href="http://www.citypages.com/about/staff/jay-boller/372121392" title="Jay Boller">Jay Boller</a>
  
  
</span>
                    </div>
                </li>
                                            
                                                                                
                <li>
                                                                                                    <a href="http://www.citypages.com/music/back-to-the-city-video-podcast-har-mar-superstar-gets-set-for-another-great-summer/421739663" title="Back to the City video podcast: Har Mar Superstar gets set for another great summer">
                        <div class="feed-image-bg bg-anchor-top" style="background-image: url('http://stmedia.stimg.co/ctyp_6625972Har_Mar_Superstar_Erik_Hess.jpg?w=390')"></div>
                    </a>
                                        <div class="feed-content">
                        <a class="list-title" href="http://www.citypages.com/music/back-to-the-city-video-podcast-har-mar-superstar-gets-set-for-another-great-summer/421739663" title="Back to the City video podcast: Har Mar Superstar gets set for another great summer">Back to the City video podcast: Har Mar Superstar gets set for another great summer</a>

                        
                        <span class="byline">

                                            2:43 p.m.
            
      
              by Simon Calder
  
  
</span>
                    </div>
                </li>
                                            
                                                                                
                <li>
                                                                                                    <a href="http://www.citypages.com/music/what-does-rock-music-even-mean-anymore-anyway/421695373" title="What does ‘rock music’ even mean anymore anyway?">
                        <div class="feed-image-bg " style="background-image: url('http://stmedia.stimg.co/dragonE061115+033.JPG?w=390')"></div>
                    </a>
                                        <div class="feed-content">
                        <a class="list-title" href="http://www.citypages.com/music/what-does-rock-music-even-mean-anymore-anyway/421695373" title="What does ‘rock music’ even mean anymore anyway?">What does ‘rock music’ even mean anymore anyway?</a>

                        
                        <span class="byline">

                                            10:44 a.m.
            
      
              by Keith Harris
  
  
</span>
                    </div>
                </li>
                                            
                                                                                
                <li>
                                                                                                    <a href="http://www.citypages.com/music/alan-jackson-coming-to-target-center-in-october-just-a-year-later-than-planned/421635333" title="Alan Jackson coming to Target Center in October -- just a year later than planned">
                        <div class="feed-image-bg bg-anchor-top" style="background-image: url('http://stmedia.stimg.co/2017_ALAN_JACKSON_EVENT_IMAGE-b1f4be35ee.jpg?w=390')"></div>
                    </a>
                                        <div class="feed-content">
                        <a class="list-title" href="http://www.citypages.com/music/alan-jackson-coming-to-target-center-in-october-just-a-year-later-than-planned/421635333" title="Alan Jackson coming to Target Center in October -- just a year later than planned">Alan Jackson coming to Target Center in October -- just a year later than planned</a>

                        
                        <span class="byline">

                                            May 8
            
      
              by Keith Harris
  
  
</span>
                    </div>
                </li>
                                            
                                                                                
                <li>
                                                                                                    <a href="http://www.citypages.com/music/kehlani-is-sweet-sexy-and-savage-at-myth/421618203" title="Kehlani is sweet, sexy, and savage at Myth">
                        <div class="feed-image-bg bg-anchor-top" style="background-image: url('http://stmedia.stimg.co/ctyp_7a35f8_160130_kehlani_160.jpg?w=390')"></div>
                    </a>
                                        <div class="feed-content">
                        <a class="list-title" href="http://www.citypages.com/music/kehlani-is-sweet-sexy-and-savage-at-myth/421618203" title="Kehlani is sweet, sexy, and savage at Myth">Kehlani is sweet, sexy, and savage at Myth</a>

                        
                        <span class="byline">

                                            May 8
            
      
              by Michael Madden
  
  
</span>
                    </div>
                </li>
                        </ul>
    
    </div>
            
            
                        <div class="OUTBRAIN" data-src="http://www.citypages.com/music/juice-lord-has-no-mercy-in-this-weeks-top-5-mn-music-videos/421678633" data-widget-id="AR_2" data-ob-template="min"></div>
            <script type="text/javascript" async="async" src="http://widgets.outbrain.com/outbrain.js"></script>
                        <div class="obtrusive-video-ad">
    <div class="convert-media-placement">
        <div class="convert-media-ad">
            <hr class="convert-media-hr" />
            <p class="convert-media-sponsored">Sponsor Content</p>
            <script type='text/javascript'>
                var pran = Math.floor(Math.random()*99999999999);
                var ppstn = "ENTER_PLACEMENT_ID_HERE";
                var purl = "//15.basebanner.com/BidRHanSer?oid=15&width=728&height=90&pubid=155467&tagid=892807&revmod=INSERT_CONTENT_TYPE&encoded=1&callback=document.write&urlonly=1";
                //var purl = "//15.basebanner.com/BidRHanSer?oid=15&width=970&height=250&pubid=155467&tagid=892807&revmod=INSERT_CONTENT_TYPE&encoded=1&callback=document.write&urlonly=1";
                document.write ("<scr"+"ipt type='text/javascript' src='" + purl);
                document.write ('&amp;pstn=' + ppstn);
                document.write ('&amp;cb=' + pran);
                document.write ("&amp;loc=" + encodeURIComponent(window.location));
                if (document.referrer) document.write ("&amp;cirf=" + encodeURIComponent(document.referrer));
                document.write ("'></scr"+"ipt>");
            </script>
        </div>
    </div>
</div>        </div>

        <div class="right-col-static">
            <!-- Used as a buffer to keep the same width as the main column -->
        </div>
    </div>

    
                </div>
            
        </main>
                <div class="skin-spacer"></div>
        
    </div>

            <footer class="col-sm-12 site-footer">
            <div class="row">

                                    <div class="leader" data-vmg-ad="Bottom" data-vmg-format="normal"></div>
                
                <div class="col-sm-5 centered">
    <img src="http://www.citypages.com/img/cp_logo-white.png" alt="City Pages" class="logo">
    <ul>
        <li><a href="https://www.facebook.com/citypages/" target="_blank"><span class="icon icon-facebook mid-light-gray"></span></a></li>
        <li><a href="https://twitter.com/citypages" target="_blank"><span class="icon icon-twitter mid-light-gray"></span></a></li>
        <li><a href="https://www.instagram.com/citypages/" target="_blank"><span class="icon icon-instagram mid-light-gray"></span></a></li>
    </ul>
</div>


<ul class="footer-nav">
            <li>
            <a href="/about" title="About">About</a>
        </li>
            <li>
            <a href="/about/contact" title="Contact Us">Contact Us</a>
        </li>
            <li>
            <a href="https://recruiting2.ultipro.com/STA1013/JobBoard/aebb97e5-139e-42ba-bc9a-ae4e64e73dd8" title="Careers">Careers</a>
        </li>
            <li>
            <a href="/about/staff" title="Staff">Staff</a>
        </li>
            <li>
            <a href="http://digital.olivesoftware.com/adl/adlauncher.asp?skin=STCityPagesADL" title="Ad Index">Ad Index</a>
        </li>
            <li>
            <a href="/advertise" title="Advertise">Advertise</a>
        </li>
            <li>
            <a href="/cpdigital" title="Digital Marketing Services">Digital Marketing Services</a>
        </li>
            <li>
            <a href="/about/privacy-policy" title="Privacy">Privacy</a>
        </li>
            <li>
            <a href="/about/terms-of-use" title="Terms">Terms</a>
        </li>
    </ul>

<p class="copyright">
    &copy; 2016 CITY PAGES. ALL RIGHTS RESERVED.
</p>            </div>
        </footer>
    
            <div class="modal modal-fullscreen modal-red" tabindex="-1" role="dialog" id="menuModal">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <div class="row">
                    <a class="col-xs-2" data-dismiss="modal" aria-label="Close"><span class="icon icon-close"></span></a>
                    <a class="col-xs-8" href="http://www.citypages.com"><img src="http://www.citypages.com/img/cp_logo-white.png" alt="City Pages" /></a>
                    <a class="col-xs-2" data-target="#searchModal" data-toggle="modal"><span class="icon icon-search"></span></a>
                </div>
            </div>

            <div class="modal-body">

                <ul class="nav-menu col-sm-12">

                                            <li class="nav-item">
                            <a href="http://www.citypages.com/news" title="News">News</a>
                            
                            
                        </li>
                                            <li class="nav-item">
                            <a class="open-categories" href="#" title="Music">Music</a>
                            
                                                            <div class="category-nav">
                                    <ul class="sub-categories">
                                        <li><a href="http://www.citypages.com/music" title="Music">All Music</a></li>
                                                                                    <li><a href="http://www.citypages.com/concerts" title="Concerts">Concerts</a></li>
                                                                            </ul>
                                </div>
                            
                        </li>
                                            <li class="nav-item">
                            <a class="open-categories" href="#" title="Food &amp; Drink">Food &amp; Drink</a>
                            
                                                            <div class="category-nav">
                                    <ul class="sub-categories">
                                        <li><a href="http://www.citypages.com/restaurants" title="Food &amp; Drink">All Food &amp; Drink</a></li>
                                                                                    <li><a href="http://www.citypages.com/restaurants/guide" title="Restaurant Guide">Restaurant Guide</a></li>
                                                                                    <li><a href="http://www.citypages.com/restaurants/reviews" title="Restaurant Reviews">Restaurant Reviews</a></li>
                                                                                    <li><a href="http://www.citypages.com/restaurants/favorite-dishes" title="Favorite Dishes">Favorite Dishes</a></li>
                                                                            </ul>
                                </div>
                            
                        </li>
                                            <li class="nav-item">
                            <a href="http://www.citypages.com/arts" title="Arts &amp; Leisure">Arts &amp; Leisure</a>
                            
                            
                        </li>
                                            <li class="nav-item">
                            <a href="http://www.citypages.com/calendar" title="Calendar">Calendar</a>
                            
                            
                        </li>
                                            <li class="nav-item">
                            <a class="open-categories" href="#" title="Movies">Movies</a>
                            
                                                            <div class="category-nav">
                                    <ul class="sub-categories">
                                        <li><a href="http://www.citypages.com/movies" title="Movies">All Movies</a></li>
                                                                                    <li><a href="http://www.citypages.com/movies/reviews" title="Film Reviews">Film Reviews</a></li>
                                                                            </ul>
                                </div>
                            
                        </li>
                                            <li class="nav-item">
                            <a href="http://www.citypages.com/best-of" title="Best Of">Best Of</a>
                            
                            
                        </li>
                                            <li class="nav-item">
                            <a class="open-categories" href="#" title="Promotions">Promotions</a>
                            
                                                            <div class="category-nav">
                                    <ul class="sub-categories">
                                        <li><a href="http://www.citypages.com/promotions" title="Promotions">All Promotions</a></li>
                                                                                    <li><a href="http://www.citypages.com/promotions/free-stuff" title="Free Stuff">Free Stuff</a></li>
                                                                                    <li><a href="http://www.citypages.com/promotions/events" title="Promotional Events">Promotional Events</a></li>
                                                                                    <li><a href="http://www.citypages.com/promotions/street-team" title="Street Team">Street Team</a></li>
                                                                                    <li><a href="http://www.citypages.com/promotions/join-street-team" title="Join The Street Team">Join The Street Team</a></li>
                                                                            </ul>
                                </div>
                            
                        </li>
                    
                </ul>

                <div class="utility-nav col-sm-12">
                    <div class="row">
                        <ul class="col-sm-12">
                                                            <li>
                                    <a href="http://www.citypages.com/this-week" title="This Week&#039;s Issue">This Week&#039;s Issue</a>
                                </li>
                                                            <li>
                                    <a href="http://www.citypages.com/slideshows" title="Photo Galleries">Photo Galleries</a>
                                </li>
                                                            <li>
                                    <a href="http://e.startribune.com/Olive/ODN/STCityPages/default.aspx" title="E-Edition">E-Edition</a>
                                </li>
                                                            <li>
                                    <a href="http://www.citypages.com/newsletters" title="Newsletters">Newsletters</a>
                                </li>
                                                            <li>
                                    <a href="http://jobfair.citypages.com" title="Job Fair">Job Fair</a>
                                </li>
                                                            <li>
                                    <a href="http://www.citypages.com/about/contact" title="Contact Us">Contact Us</a>
                                </li>
                                                    </ul>

                        <div class="col-sm-12 social-icons">
                            <a class="circle" href="https://www.facebook.com/citypages/" target="_blank">
                                <span class="icon icon-facebook"></span>
                            </a>
                            <a class="circle" href="https://twitter.com/citypages" target="_blank">
                                <span class="icon icon-twitter"></span>
                            </a>
                            <a class="circle" href="https://www.instagram.com/citypages/" target="_blank">
                                <span class="icon icon-instagram"></span>
                            </a>
                        </div>
                    </div>
                </div>

            </div>

            <div class="modal-footer">

                
<ul class="footer-nav">
            <li>
            <a href="/about" title="About">About</a>
        </li>
            <li>
            <a href="/about/contact" title="Contact Us">Contact Us</a>
        </li>
            <li>
            <a href="https://recruiting2.ultipro.com/STA1013/JobBoard/aebb97e5-139e-42ba-bc9a-ae4e64e73dd8" title="Careers">Careers</a>
        </li>
            <li>
            <a href="/about/staff" title="Staff">Staff</a>
        </li>
            <li>
            <a href="http://digital.olivesoftware.com/adl/adlauncher.asp?skin=STCityPagesADL" title="Ad Index">Ad Index</a>
        </li>
            <li>
            <a href="/advertise" title="Advertise">Advertise</a>
        </li>
            <li>
            <a href="/cpdigital" title="Digital Marketing Services">Digital Marketing Services</a>
        </li>
            <li>
            <a href="/about/privacy-policy" title="Privacy">Privacy</a>
        </li>
            <li>
            <a href="/about/terms-of-use" title="Terms">Terms</a>
        </li>
    </ul>

<p class="copyright">
    &copy; 2016 CITY PAGES. ALL RIGHTS RESERVED.
</p>
            </div>

        </div>
    </div>
</div>        <div class="modal modal-fullscreen modal-red" tabindex="-1" role="dialog" id="searchModal">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <a class="close-button right" data-dismiss="modal" aria-label="Close">
                    Close
                    <span class="icon icon-close" aria-hidden="true"></span>
                </a>
                <h4 class="modal-title">Search</h4>
            </div>
            <div class="modal-body">
                <form class="form-red" action="http://www.citypages.com/search" method="get">
                    <div class="row">
                            
<div class="col-sm-4">
      <div class="form-group ">
        
    <div class="form-select">
      <select
                  id="contentType"
                                      name="contentType"
                          >
                  <option value="All">ALL CONTENT</option>
                  <option value="Article">ARTICLES</option>
                  <option value="Event">EVENTS</option>
                  <option value="Photo gallery">PHOTO GALLERIES</option>
                  <option value="Best Of">BEST OF</option>
                  <option value="Venue">VENUES</option>
                  <option value="Restaurants and Bars">RESTAURANTS AND BARS</option>
              </select>
    </div>
    
  </div>

</div>                    </div>
                    <div class="input-row">
                        <input id="search" name="q" type="text" value="" placeholder="Type something" />
                        <button class="right" type="submit">Search</button>
                    </div>
                </form>

            </div>
        </div>
    </div>
</div>        <div class="modal modal-fullscreen modal-red" tabindex="-1" role="dialog" id="dateModal">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <a class="today-link"><i class="fa fa-undo"></i> back to today</a>
                <a class="close-button right" data-dismiss="modal" aria-label="Close">
                    Close
                    <span class="icon icon-close" aria-hidden="true"></span>
                </a>
            </div>
            <div class="calendar-picker"></div>
        </div>
    </div>
</div>
        
<div class="modal modal-fullscreen modal-filter" tabindex="-1" role="dialog" id="calendarFilterModal">
                        <div class="datebar in-modal">
        <h2 class="datebar-title">Calendar</h2>
        <a class="datebar-btn-today active">Today</a>
        <a class="datebar-btn-datepicker" data-target="#dateModal" data-toggle="modal">
            <i class="fa fa-calendar"></i> <span class="month-only">May</span>        </a>
        <div class="datebar-dates">
                        <a class="datebar-btn datebar-btn-left" data-offset="-1" disabled><i class="fa fa-angle-left"></i></a>
            <a class="datebar-btn-datepicker" data-target="#dateModal" data-toggle="modal">
                <i class="fa fa-calendar"></i> <span class="month-day">May 10</span>            </a>

                                            
                <a class="datebar-btn datebar-btn-date "
                    data-offset="-2" disabled>
                                        8
                </a>
                                            
                <a class="datebar-btn datebar-btn-date "
                    data-offset="-1" disabled>
                                        9
                </a>
                                            
                <a class="datebar-btn datebar-btn-date active"
                    data-offset="0">
                                        10
                </a>
                                            
                <a class="datebar-btn datebar-btn-date "
                    data-offset="1">
                                        11
                </a>
                                            
                <a class="datebar-btn datebar-btn-date "
                    data-offset="2">
                                        12
                </a>
                        <a class="datebar-btn datebar-btn-right" data-offset="1"><i class="fa fa-angle-right"></i></a>
        </div>
        <a onclick="$('.modal').modal('hide');" class="datebar-btn-close"><i class="fa fa-close"></i></a>
        <a class="datebar-btn-filter" data-target="#calendarFilterModal" data-toggle="modal">
            <i class="fa fa-filter"></i><span class="datebar-filter-count hidden">0</span>        </a>
        <a class="datebar-btn-search" data-target="#searchModal" data-toggle="modal" data-search-content-type="Event"><span>Events</span> <i class="fa fa-search"></i></a>
    </div>
      <div class="statusbar in-modal">
    <div class="statusbar-table">
      <div class="statusbar-cell">
        <h2 class="statusbar-title"></h2>
        <span class="statusbar-results statusbar-results-first">
                                      </span>
      </div>
      <div class="statusbar-cell">
        <div class="statusbar-filters">
                            </div>
      </div>
      <div class="statusbar-cell statusbar-footer">
        <span class="statusbar-results statusbar-results-last">
                  </span>
        <a class="statusbar-clear">Clear Filters</a>
      </div>
    </div>
  </div>
    <div class="quicksearch">
    <h3>Quick Search</h3>            <div class="quicksearch-row row">
            <div class="col-xs-6">
                <a class="button active" data-filter="Recommended">Recommended</a>
            </div>
            <div class="col-xs-6">
                <a class="button" data-filter="All Events">All Events</a>
            </div>
            <div class="col-xs-6">
                <a class="button" data-filter="Music">Music</a>
            </div>
            <div class="col-xs-6">
                <a class="button" data-filter="Theater">Theater</a>
            </div>
            <div class="col-xs-6">
                <a class="button" data-filter="Comedy">Comedy</a>
            </div>
            <div class="col-xs-6">
                <a class="button" data-filter="Art">Art</a>
            </div>
            <div class="col-xs-6">
                <a class="button" data-filter="Dance">Dance</a>
            </div>
            <div class="col-xs-6">
                <a class="button" data-filter="Food and Drink">Food &amp; Drink</a>
            </div>
        </div>
    </div>
    <div class="addfilter">
    <h3>Add Filter</h3>
    <ul class="addfilter-filters">        
            </ul>

    
</div>
</div>
        <div class="modal modal-fullscreen modal-interstitial" tabindex="-1" role="dialog" id="interstitialModal">
    <div class="modal-dialog">
        <div class="modal-content" >

            <div id="interstitialContainer" class="text-center" style="margin-top:25px; margin-bottom:25px;">
                <div data-vmg-ad="Interstitial"></div>             </div>

            <div class="border-block">
                <p class="text-center">
                    <a class="cta-link" onclick="$('.modal').modal('hide');">Continue to Site</a>
                </p>
            </div>


        </div>
    </div>
</div>
        

<div class="modal modal-subscribe" tabindex="-1" role="dialog" id="subscribeModal">

    <div class="modal-dialog">
        <div class="modal-content">

                <div class="modal-header">
                    <a class="close" data-dismiss="modal" aria-label="Close"><span aria-hidden="true">&times;</span></a>
                    <div class="logo">
                        <img src="http://www.citypages.com/img/cp_logo-white.png"/>
                    </div>
                </div>
                <div class="modal-body">
                    <h2 class="text-center">Newsletters</h2>
                    <p class="text-center">All-access pass to top stories, events and offers in the Twin Cities.</p>
                    <div class="row">
                        <div class="col-xs-12">
                            <form id="lightbox-subscribe" data-endpoint="http://signup-collector.e2ma.net/signup" data-account-id="1788366">
                                <div class="form-group">
                                      <div class="form-group required">
          <label for="email" class="control-label ">Email</label>
        
    <input
              id="email"
                                          name="email"
                                                                    required="1"
                                            class="form-control"
      type="email"
      >
    
  </div>

                                </div>
                                                                    <div class="row">
                                                                                    <div class="col-xs-6">
                                                  <div class="form-group ">
    
    <div class="checkbox ">
      <label onclick="">
        <input
                                            name="2747854"
                                                                  checked="checked"
                                      type="checkbox"><span></span> Music
      </label>
    </div>
    
  </div>

                                            </div>
                                                                                    <div class="col-xs-6">
                                                  <div class="form-group ">
    
    <div class="checkbox ">
      <label onclick="">
        <input
                                            name="2750926"
                                                                  checked="checked"
                                      type="checkbox"><span></span> Things to Do
      </label>
    </div>
    
  </div>

                                            </div>
                                                                            </div>
                                                                    <div class="row">
                                                                                    <div class="col-xs-6">
                                                  <div class="form-group ">
    
    <div class="checkbox ">
      <label onclick="">
        <input
                                            name="2743758"
                                                                  checked="checked"
                                      type="checkbox"><span></span> Food & Drink
      </label>
    </div>
    
  </div>

                                            </div>
                                                                                    <div class="col-xs-6">
                                                  <div class="form-group ">
    
    <div class="checkbox ">
      <label onclick="">
        <input
                                            name="2751950"
                                                                  checked="checked"
                                      type="checkbox"><span></span> This Week in City Pages
      </label>
    </div>
    
  </div>

                                            </div>
                                                                            </div>
                                
                                <div class="padding-slates">
                                    <div class="form-group">
                                        <script src="https://www.google.com/recaptcha/api.js" async defer></script>
                                        <div class="g-recaptcha" data-size="normal" data-sitekey="6LcMCwgTAAAAAM86pPA6G1eIFDlL7iaeT3Y81A0Q"></div>
                                    </div>
                                </div>

                                <div class="row">
                                    <div class="col-sm-12">
                                        <button type="submit" id="sign-up" class="btn-block">Sign Up</button>
                                    </div>
                                </div>
                                <div class="row">
                                    <div class="col-sm-12">
                                        <button type="button" data-dismiss="modal" id="no-thanks" class="btn-block btn-link">No Thanks!</button>
                                    </div>
                                </div>

                                    <!-- <a href="/about/privacyPolicy/" class="privacyPolicy" target="_blank">Privacy Policy</a> -->
                            </form>
                        </div>
                    </div>
                </div>
        </div>
    </div>
</div>
    
            <script src="http://www.citypages.com/build/js/app.min-b2e4b4a951.js" data-vmg-ad-script></script>
    
    

    
    
<!-- <script type="text/javascript" src="//native.sharethrough.com/assets/tag.js" async=""></script> -->
<script type="text/javascript" src="//native.sharethrough.com/assets/sfp.js" async ></script>

<script>
    window.dataMapManager = window.dataMapManager || {};
    window.dataMapManager['adsInitJSON'] = {
        "url": "oascentral.citypages.com",
        "positions": ["Frame","Billboard","Middle","Bottom","Interstitial"],
        "site_page": "www.citypages.com/music",
        "query": "XE&Category=Article&Subcategory=Music&XE",
        "debug": 0,
        "sharethroughKeys": null,
        "sharethroughPlacement": null
    };
</script>
    <script type='text/javascript'>
    var _sf_async_config = _sf_async_config || {};
    var _sf_async_config = {};
    _sf_async_config.uid = 19787;
    _sf_async_config.domain = 'citypages.com';
    _sf_async_config.useCanonical = true;
    _sf_async_config.sections = 'Music';
    _sf_async_config.authors = 'citypages.com';
    (function() {
        function loadChartbeat() {
            window._sf_endpt = (new Date()).getTime();
            var e = document.createElement('script');
            e.setAttribute('language', 'javascript');
            e.setAttribute('type', 'text/javascript');
            e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
            document.body.appendChild(e);
        }
        var oldonload = window.onload;
        window.onload = (typeof window.onload != 'function') ?
            loadChartbeat : function() {
                oldonload();
                loadChartbeat();
        };
    })();
</script>

<!--  Quantcast Tag -->
<script>
    var ezt = ezt ||[];

    (function(){
        var elem = document.createElement('script');
        elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://pixel") + ".quantserve.com/aquant.js?a=p-a4LDpi_DEopn-";
        elem.async = true;
        elem.type = "text/javascript";
        var scpt = document.getElementsByTagName('script')[0];
        scpt.parentNode.insertBefore(elem,scpt);
    }());


    ezt.push({qacct: 'p-a4LDpi_DEopn-',
        uid: ''
    });
</script>
<noscript>
    <img src="//pixel.quantserve.com/pixel/p-a4LDpi_DEopn-.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
</noscript>
<!-- End Quantcast Tag -->
        
<script>/* <![CDATA[ */(function(d,s,a,i,j,r,l,m,t){try{l=d.getElementsByTagName('a');t=d.createElement('textarea');for(i=0;l.length-i;i++){try{a=l[i].href;s=a.indexOf('/cdn-cgi/l/email-protection');m=a.length;if(a&&s>-1&&m>28){j=28+s;s='';if(j<m){r='0x'+a.substr(j,2)|0;for(j+=2;j<m&&a.charAt(j)!='X';j+=2)s+='%'+('0'+('0x'+a.substr(j,2)^r).toString(16)).slice(-2);j++;s=decodeURIComponent(s)+a.substr(j,m-j)}t.innerHTML=s.replace(/</g,'&lt;').replace(/\>/g,'&gt;');l[i].href='mailto:'+t.value}}catch(e){}}}catch(e){}})(document);/* ]]> */</script></body>
</html>
